How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., RV tech - emphasis on gensets
Category: RV
Satisfied Customers: 14489
Experience:  RV tech since the beginning of the millenium.
19372534
Type Your RV Question Here...
Hank F. is online now
A new question is answered every 9 seconds

Have a Onan Marquis 5500 in toyhauler. Gen stats fine, runs

Customer Question

Have a Onan Marquis 5500 in toyhauler. Gen stats fine, runs fine, have 110 output fine. Not charging the battery or boosting the 12 volt system when running. Don't here the invertor click nor the fan running after star up.
Submitted: 1 year ago.
Category: RV
Expert:  Hank F. replied 1 year ago.

If the genset is running, it is producing power.

Your problem is that either the 120 is not getting to your converter, or your converter is bad.

If you have a stand alone converter, check the receptacle that it is plugged into and make sure you have 120V at the receptacle.

If your converter is part of your power control center, you can simply check for 120V right at the breaker that the converter is connected to.

If you have a stand alone converter, most of them have 1 or 2 main fuses on the outside. Check to make sure the fuse(s) are not blown.

If you have 120V getting to the converter, but do not have about 13.6V coming out, the converter is bad and will need to be replaced.

Expert:  Hank F. replied 1 year ago.

Was this what you wanted to know?