How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10326
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

I am trying to find the fuse 7 pin tch plug. Can anyone tell

Customer Question

I am trying to find the fuse for the 7 pin hitch plug. Can anyone tell me where to find it?
Thanks in advance.
Submitted: 1 year ago.
Category: RV
Expert:  Randall replied 1 year ago.

There won't be just one fuse...........each function in there has a separate fuse. What is not working?

Customer: replied 1 year ago.
Left turn and brake are not working. Have looked at at least 3 different panels and I'm not seeing any of the fuses that would be related to that. I found a box way up front but I believe those fuses to be the coach signals and not for the 7 pin tow harness. Plus, all those fuses are intact.I called Freightliner and they said it would be in the back near the batteries. There is a box there, but nothing that says 'turn signals', 'brakes', etc...I admittedly don't know what all of the fuses are however.
Customer: replied 1 year ago.
I should be more specific, my coach signals are all working just fine. It is only when I connect to the 7 pin tow plug that I am not getting all of my signals. Verified that signals are all working by hooking trailer up to another vehicle. All signals and brakes work just fine on the other vehicle.
Customer: replied 1 year ago.
FOUND THEM!!! They are in the ECU compartment. A screwed in panel that has fuses and relays in it. I would have never guessed. Both 20A fuses were shot. I will replace them and follow-up.
Expert:  Randall replied 1 year ago.

Sorry for the delay in getting back to you..........but, glad you tracked them down! IF you have an issue AT the plug on the brake or turn signals, it can be the taillight converter which is a small black box tucked up under the hitch area. Those go bad frequently. Test that with a 12 VDC test light. Hopefully that will resolve this for you. Get back to me if you need more later as all follow ups are included in our fee.