How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., RV tech - emphasis on gensets
Category: RV
Satisfied Customers: 14487
Experience:  RV tech since the beginning of the millenium.
19372534
Type Your RV Question Here...
Hank F. is online now
A new question is answered every 9 seconds

I have an Oman 4000 emerald plus. After it has been running

Customer Question

I have an Oman 4000 emerald plus. After it has been running awhile and I shut is down. I have to let it sit for a couple of hours before it will restart?
Submitted: 1 year ago.
Category: RV
Expert:  Blake Pankratz replied 1 year ago.

Hi my name is ***** ***** I can help you out. Can you please give me the complete model number of the generator?

Customer: replied 1 year ago.
The trailer it is in is in storage. I have a picture of the generator, but I can't make out the numbers.
Customer: replied 1 year ago.
Hello?
Expert:  Blake Pankratz replied 1 year ago.

Does the generator output 11th while it's running? The generator can sense no output and shut itself down. Is it full of oil? It could also shut down due to low oil pressure.

Customer: replied 1 year ago.
The generator runs fine, and starts good when it is cold. When "I" shut it down, it will not restart unless I let it sit for a few hours.
Customer: replied 1 year ago.
It's like it has to be cool to restart. Is there an temp sensor that may be faulty?
Expert:  Blake Pankratz replied 1 year ago.

It could be a faulty temp sensor. It's odd that it would only happen when you shut it down though.

Expert:  Blake Pankratz replied 1 year ago.

I'm sorry I will have to let another tech handle this. Thank you for your time.

Expert:  Hank F. replied 1 year ago.

Hello, my name is ***** ***** I am going to assist you with this.

I'm sorry, but I am going to need the model number of the genset.

This is a BGE series unit, and there are 17 different variations of it. I need to know exactly which one you have.

Customer: replied 1 year ago.
Roger that. I will have to go to the storage yard tomorrow then.
Expert:  Hank F. replied 1 year ago.

OK.

.

Customer: replied 1 year ago.
Here is a picture of the tag sir.
Expert:  Hank F. replied 1 year ago.

You didn't have to go through all that. You could have just told me the model number.

Fortunatly for you, the newer BGE's are my absolute favorites, and are very easy to work on.

Lets start with determining which subsystem is responsible for the engine not wanting to stat when hot.

Remove the air filter.

Start the engine, and let it run for a while, preferably with a load on it, to let it get good and hot.

Shut the unit down.

See if it will restart. Remember, we have to catch it while it is not starting, so if it does restart, ket it run some more.

Once you have it to where it will not restart, check to see if your are getting fire to both plugs. If not, we know we have an ignition system issue.

If you are getting spark, while craning the engine, start spraying in some carb cleaner. Do NOT use starting fluid.

Will the engine start on carb cleaner? If so, you have a fuel issue.

Let me know what you find.

Customer: replied 1 year ago.
The trailer is in storage, I am at work.
Expert:  Hank F. replied 1 year ago.

That is where we need to start.

Just let me know when you have checked that, and what happened.

.