How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, RV Mechanic
Category: RV
Satisfied Customers: 8454
Experience:  Work on several type of Rv engine, Trans, brakes
6825259
Type Your RV Question Here...
Wayne is online now
A new question is answered every 9 seconds

I have an onan 4000 microquiet (1999). It was working

Customer Question

I have an onan 4000 microquiet (1999). It was working perfectly until I changed the batteries. My positive battery line is hot to the solenoid and I changed out the solenoid but there is still no power to the generator. I was told that some of these generators have a "reset" switch if you change the batteries but I could not find one....
Submitted: 1 year ago.
Category: RV
Customer: replied 1 year ago.
sorry that is a microlite not microquiet
Expert:  Wayne replied 1 year ago.

Hi I'm Wayne

I will try to help you with this

does your solenoid have 3 wires on it

2 big and 1 small, let me know

Expert:  Wayne replied 1 year ago.

Hi I'm Wayne

I will try to help you with this

does your solenoid have 3 wires on it

2 big and 1 small, let me know

Customer: replied 1 year ago.
just two wires...on the top
Expert:  Wayne replied 1 year ago.

Thank you for that

do you have power from the battery terminal

to the other side of the solenoid

also did the old one have just 2 wires

Customer: replied 1 year ago.
I have power to the solenoid from the batteries....and I put in a new solenoid...checked all connections...as I said I was told by Onan that some units have a reset switch on them when you change batteries...I could not find it.
Customer: replied 1 year ago.
same exact solenoid from Onan. Like I said this all happened after I changed the batteries.
Expert:  Wayne replied 1 year ago.

Hi

should be a reset on the control Board , did you look there