How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., RV tech - emphasis on gensets
Category: RV
Satisfied Customers: 14489
Experience:  RV tech since the beginning of the millenium.
19372534
Type Your RV Question Here...
Hank F. is online now
A new question is answered every 9 seconds

Have problem starting generator. Model is adventurer w/onan

Customer Question

Have problem starting generator. Model is adventurer w/onan 5500. Dry camped this weekend heat ran down batteries, checked amp gauge = 9amps. Shut everything down hit battery boost button & generator start same time, generator didn't start. Hooked to ground power for charge still can't start gen. Generator normally starts on first crank. Generator turns over thats all. Please help!
Submitted: 1 year ago.
Category: RV
Expert:  peterpete190 replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Inspect the fuel feed line and fuel filter to the generator and see if any fuel issues are found.I have seen before where a damaged or restricted fuel line or fuel filter will cause this issue here with the fault needing replaced to correct this issue.If this has already been inspected and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete.

Customer: replied 1 year ago.
Thanks Pete for replying. Fuel line & filter is not the issue. Generator is in good condition, 250 hrs. Ran fine 8 hrs earlier. I think something (elec) tells gen. Don't run.
Like a low oil pressure interrupt.
Expert:  peterpete190 replied 1 year ago.

Your welcome.

Was the oil level checked to see if it was o.k.?

Have you checked wiring to the generator to see if any wiring is found loose or damaged at all?

Customer: replied 1 year ago.
I have good oil level & wiring is is tight. I checked all fuses.. Generator doesn't even put. Like it needs to be reset or something
It s like trying to start your without turning the ignition switch on first.
Expert:  peterpete190 replied 1 year ago.

O.k.,unfortunately this is all the info I have on this myself here.I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Expert:  Hank F. replied 1 year ago.

Hello, my name is ***** ***** I am going to assist you with this.

What is the full model number of the genset, exactly as it is written on the data label?

Is this unit running on LP or gasoline?

How much fuel do you have?

Is the genset cranking normally, or is it cranking abnormally slow?

Customer: replied 1 year ago.
Hi Hank, I will contact u later with the additional info u requested. In speaking with others it appears a fault May be responsible it has a diagnostic system Ken
Expert:  Hank F. replied 1 year ago.

OK

.