How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 10393
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

Just installed new Suburban SW6D direct spark ignition hot

Customer Question

Just installed new Suburban SW6D direct spark ignition hot water heater. Connected water lines and propane. Filled and leak checked, all o.k. Turned remote switch on, red light goes on, no ignition. Hit reset and retry, also reset ECO and t-stat, no luck. Tried many times as per instructions. My concern: Why red light stays on (indicates lockout) and no ignition. What am I missing?
Submitted: 1 year ago.
Category: RV
Expert:  Randall replied 1 year ago.

Check and see if you knocked the plug loose on the control board OR the high tension lead on the board. Perhaps the board is bad. Can happen. If you don't see anything obvious, then perhaps have the control board tested. Those would be the obvious things. Hope that proves helpful here. Please get back to me if you need more as all follow ups are included in our fee.