How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Fix-it.. Your Own Question
Fix-it..
Fix-it.., Commercial Transport Technician
Category: RV
Satisfied Customers: 1160
Experience:  15 yrs. experience as Class A Motor Home chassis specialist.
35815791
Type Your RV Question Here...
Fix-it.. is online now
A new question is answered every 9 seconds

Buddy, I have a 1998 cat engine on a freightliner chasis

Customer Question

Hi Buddy, I have a 1998 cat engine on a freightliner chasis Newmar Dutch Star motorhome. I have had the ECM replaced and afterward the RPM and speedometer both have no readings. This sounds like something you may be familiar with. How should I proceed?
Submitted: 1 year ago.
Category: RV
Expert:  Fix-it.. replied 1 year ago.

Good evening

Yes this is common after a ecm replacement. Looks like a couple of parameters are set wrong and you will have totake it back and have the parameter set properly

Customer: replied 1 year ago.
I already tried that with a diesel truck repair shop (Reparation Montreal). They couldn't fix the parameters and said to try Freightliner. Which parameters are involved? Why would they be unable to correct them? Could it be some deficiency in the replacement ECM that I had exchanged?
Expert:  Fix-it.. replied 1 year ago.

Please send me the parameter list I'll need to see it

Expert:  Fix-it.. replied 1 year ago.

Everything worked fine before the ecm was done correct?

Customer: replied 1 year ago.
Hi, Yes everything worked just fine before the Ecm failed. Since then Reparation Montreal changed out some sensors as the documentation showed the voltage as "high". There is a long list of parameters that I will scan and forward to you. The one that they seemed hung up on was "powertrain data link" with a description of "11939". They seemed to either enter the description as that number "11939" or "none" as their only two choices and neither of these worked. I will try to find a scanner and send you the entire Electronic Technician report. The problem is they completely gave up after this point and said " take it somewhere else - maybe to Freightliner". Were they close to the problem or at least in the right ballpark? I will probably take it back to Caterpillar when I get back (we're on a three month trip right now and headed to Montreal this week ) because they did the original reprogramming on the replacement Ecm, but I would like to know where the problem is specifically and what is involved because my two first attempts were frustrating and expensive. Caterpillar were so busy that they returned the reprogrammed Ecm for me to install myself and could not take the unit in afterward for some time so I had to find another repair facility - Reparation Montreal.
Expert:  Fix-it.. replied 1 year ago.

Wow

eather way it has to go to a shop with cat et software. Let me know if you have any more questions

Customer: replied 1 year ago.
I will return to Hewitt Caterpillar in Montreal to see if they have the time to finish the programming to try and retrieve my RPM and speedometer functions. I have added the technician's data from the last attempt to complete this work. If you have any additional comments I would appreciate them.
Expert:  Fix-it.. replied 1 year ago.

Thanks for that

Did you try selecting the power train data link to 1587?