How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12357
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

We have a wildwood travel trailer when we try to use the

Customer Question

We have a wildwood travel trailer when we try to use the battery it does not work when we use a generator or plug into power it works took to a dealer as we smelled burning wires my husband thinks it could be the converter but they said no they fixed the wires and we picked it up and we still have the same problem after putting in yet another new battery and it still smells like something is burning we have extended warranty but it seems like they can't be bothered to help us our first bill was 140.00 for nothing do u have any idea what we should do next this is a 2014 so it's not an old unit
Submitted: 1 year ago.
Category: RV
Expert:  Robert replied 1 year ago.

Hi my name is Robert...

When you are plugged into power the power converter will take the AC voltage and make the DC voltage and charge the battery, when you unplug from power the power converter will switch over to battery power. Sometimes they will stick an auto breaker between the power converter and battery, below is a picture, as a general rule IF you had one it would be 18" from the battery, some are thermal and self reset and others have a small tab on them that pop out when they trip. The voltage on each post should be very close. Also you might have more then one, sometimes the slides/landing gear might have one. IF you do not see one and it is not working when you disconnect chances are the power converter is bad and would need to be replaced... Hope this helps IF you have more questions or concerns please feel free to contact me.... Robert