How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: RV
Satisfied Customers: 27146
Experience:  Over 17 years diagnosing and repairing various model vehicles.
14928985
Type Your RV Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I have a Southwind Fleetwood 36D Motor Home... Resolved 27

Customer Question

I have a Southwind Fleetwood 36D Motor Home... Resolved 27 Aug 2015 I have a Southwind Fleetwood 36D Motor Home with two vacuum toilets. The rear one is working as it should but the fro t one has no suction and wont drain. The green light that says ts
reDy comes on. We have tried a plunger to no avail. What can we do to make it work
Submitted: 1 year ago.
Category: RV
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  peterpete190 replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.

I would have the toilet and drain as well as any air inlet checked for restrictions as usually this is the cause for this type of fault here.This may need checked into by an authorized repair center or dealer to locate and correct this issue.

Thanks Pete

Customer: replied 1 year ago.
Thanks but this does not give me any help
Expert:  peterpete190 replied 1 year ago.

I apologize for this as this is all of the info I have myself.I will have to open this question up for others here to see if they can assist further on this as someone else here may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.

Thanks Pete