How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, RV Mechanic
Category: RV
Satisfied Customers: 9341
Experience:  Work on several type of Rv engine, Trans, brakes
6825259
Type Your RV Question Here...
Wayne is online now
A new question is answered every 9 seconds

I have a 2006 400isl cummings had a no start condition. only

Customer Question

i have a 2006 400isl cummings had a no start condition . only started with wd 40 after a few cranks changed all filters started no problem . ran a couple of hours no problem stalled out backing in to my spot . would not start couldnt hear the lift pump run. after a couple of hours sitting it started right up. what do do next?
Submitted: 1 year ago.
Category: RV
Expert:  Wayne replied 1 year ago.

Hi

I'm Wayne

I will help you with this

Replace your lift pump,

I have seen this several times

it gets weak, and lets fuel drain back

but the check valve at filter holds that prime

I suggest to replace Lift Pump ..........

If this Helped you please Rate My Answer 3 stars or more

If you need more info

Use the request Button, not a Poor/Bad Rating

Thank You

Wayne

Customer: replied 1 year ago.
Hi wayne i changed my lift pump and relay . now there is no power going to the relay and my wait to start lamp does not lite up?
Expert:  Wayne replied 1 year ago.

Morning

did you check all your breakers and fuses

this just happen after you replaced the relay,

go back and check that the terminals did not get pushed

out of the socket

Related RV Questions