How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 12155
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

Hey robert im i have a 2004 holiday rambler with a

Customer Question

hey robert im bernie i have a 2004 holiday rambler with a 1200lrim frig that bus supply installed artic cool cooling unit in iam getting a no co sign on door i have reset board by grounding pin 15 and it would reset and run for about 2 hrs on ac and longer on lp but as the days progressed it ran for less time and frig stopped cooling freezer still worked then after a few days wouldnt run longer than a couple minute on either then go to no co message even unplugged thermistor did not help
Submitted: 1 year ago.
Category: RV
Expert:  Robert replied 1 year ago.
Hi my name is Robert....
This really sounds like the cooling unit is not working. The NO CO code will come up when there is a high temp shutdown, not only that the run time has been getting less before the code comes back. When you unplug that thermistor it should have went to full cooling as well. I can get you a service manual on this if you feel it will help. This will allow you to check proper clearances in the box....
Robert
Customer: replied 1 year ago.
Could it be the small fans maybe
Customer: replied 1 year ago.
If it doesn't go into lock out it would freeze in freezer. Are you saying that there is actually no coolant in unit ?
Expert:  Robert replied 1 year ago.
OK
The fans should be running if it is getting really hot, so verify they are coming on...
The freezer will always get cold long before the box, so it is possible to have a coolant unit issue. The ammonia solution is not moving or circulating in the cooling unit, it could be blocked. For a rupture you would smell ammonia, see a yellowish powder on the back of the fridge and sometimes hear a gurgle when it is turned on...
Sometimes you can get a bad cooling unit it has happened to me more then once.
Below is a link for a service manual, I would verify the fan operation, check your clearance in the box...
http://bryantrv.com/docs2/docs/ncold1200.pdf
Customer: replied 1 year ago.
I'm just remembering that two weeks before it completely went out I had a code saying lo dc then reset and code came on saying hi dc.
Expert:  Robert replied 1 year ago.
OK Sometimes but very rare a power converter can put out AC ripple and the circuit board does not like it. What you can try to do is hook up a battery direct and see if the fridge runs. I highly doubt this is the issue since the fridge is actually running and then shutting down, the key is the shorter time frames and points to the cooling unit. However I would take a look at the manual and verify everything is installed correctly, make sure it is level. Hope this helps......
Robert