How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask gene Your Own Question
gene
gene, RV Mechanic
Category: RV
Satisfied Customers: 1100
Experience:  28 yrs exp in the industry
19317657
Type Your RV Question Here...
gene is online now
A new question is answered every 9 seconds

Randall, I hve a 2007 Monaco Knight with dual 13500 btu

Customer Question

Hi Randall, I hve a 2007 Monaco Knight with dual 13500 btu Dometic penquin heat pump roof units. Just had to replace a blown start capacitor (replaced with a hard start) on the bedroom unit and now it starts fine, blows cold air at first, then the air just gets gradually warmer until it doesn't cool at all. I cleaned both coils and replaced the gasketing around the condenser coil while I had the unit open and the filter is clean My guess was a low charge and then I was told they can't be charged. What do you think?
Submitted: 1 year ago.
Category: RV
Expert:  Michael Reush replied 1 year ago.
Hi, it could be a low charge, the way to tell the charge is use an amp probe, and read the amperage to the compressor. You will see a data plate on it that has the specs on it, your looking for the FLA rating. Can it be charged, thats interesting, back in the day we would repair and recharge. but dont anymore. too problematic, and new unit comes with full factory warranty, please get back to me , and we can discuss it further
Customer: replied 1 year ago.
Is low charge consistent with the fact that it cools at first but then just dies on the vine? Don't really want to spend $800 on a new unit.
Expert:  Michael Reush replied 1 year ago.
No , that doesnt make sense, and I understand you not wanting to spend the $$$$$$ the amp test will tell us what the compressor is doing, and if its breaking down as its running, my first thought was that it is freezing up, and you have done the first indicated step, to clean the evaporator do you see ice on the evap> or on the tubes running from the compressor to it?
Customer: replied 1 year ago.
I'll have to open the unit back up tomorrow, it's storming here in FL for the rest of the night. I'll check the running amps and look for ice on the lines, anything else I should look for?
Expert:  Michael Reush replied 1 year ago.
look for oily discharge anywhere at the topside, actual temps would be helpful, ambient temp, running temp and the degrees as it falls
Customer: replied 1 year ago.
Thanks
Expert:  Michael Reush replied 1 year ago.
I look forward to hearing from you tomorrow, please wait to respond as I must address each response, thanks.......Michael