How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Nick Your Own Question
Nick
Nick, RVIA Certification
Category: RV
Satisfied Customers: 663
Experience:  5 years RV repair and reconstruction, Fleetwood RV Training course completion.
10390867
Type Your RV Question Here...
Nick is online now
A new question is answered every 9 seconds

Travel trailer..heater works..winterization but tech at RV dealership

Customer Question

Just purchased a Palomino Puma travel trailer, hot water heater works but cannot seem to get straight hot water to the sink/shower. There is only 1 valve on the back of the water heater at 0 degrees no water when hot is turned on at faucet, 90 degrees get hot and cold mixed. Must be related to winterization but tech at RV dealership not much help.
Submitted: 7 years ago.
Category: RV
Expert:  Nick replied 7 years ago.
sounds like it is a mixing problem..
since you only have 1 valve, i am assuming it is at the bottom fitting of the tank correct?
Customer: replied 7 years ago.
Yes you are correct
Expert:  Nick replied 7 years ago.
ok.... well this valve should be flat... as in open.. parallel to the water line... there is a one way check valve on the top fitting of the tank.. which allows hot water out, but not in... sometimes these can get debris in them, which would usually get washed away but when winterized, dries and sticks.. if this valve is stuck open or part open, it will mix with cold water which will produce warm...
this valve may also be broken and not opening completely.. depends on the set up... if it is a valve, that is in a T, directional valve. then this can sometimes get stuck, the handle can slip and it will allow water both ways, mixing it.. if it is in the middle of the line, with only one line in and out, then it doesnt mix...
first i would ensure your heater is operating correctly.. let it run then at the pop off valve outside, make sure you have hot water comming from that.. be careful, dont touch it, it will burn.. you will know if it is hot...
if you have hot water and confirm the heater is working... i would be looking at the valve or the check valve on the tank...you can check the shut off valve by, removing it and replacing it... they are available from lowes etc or camping world...
if you still have a problem, i would be changing the check valve on the tank.... a little more involved but sitll possible....


Thankyou for your question.. please remember this is the answer page and to click accept if you are satisfied with my answer so i get paid for my efforts.. Please also note, accepting my answer does not terminate our correspondance, you may continue to reply after accepting and i will work with you until the problem is solved.
thankyou and please let me know if you require further assistance.....

:Nick:

Nick and other RV Specialists are ready to help you
Customer: replied 7 years ago.

I will check this out tomorrow and let you know what I find.

 

thanks for the answer.

 

Mark

Expert:  Nick replied 7 years ago.
no problem.. let me know