How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Nathan Your Own Question

Nathan
Nathan, Engineer
Category: Printers
Satisfied Customers: 20544
Experience:  Computer networking/repair. 12+ years experience.
59725966
Type Your Printers Question Here...
Nathan is online now
A new question is answered every 9 seconds

RE CanonMP 530 Get error message5100 Printer unit doesn't

Customer Question

RE CanonMP 530
Get error message5100 Printer unit doesn't illuminate nor does on/off button.Copy button is illuminated Have turned unit on and off several times but nothing happens.
Advice?
Submitted: 3 months ago.
Category: Printers
Expert:  Nathan replied 3 months ago.

Hello, I’m Nathan, and I’ll be assisting you today.

Sorry to hear that you’re having trouble with this but I’ll do my best to help you out.

This message indicates a carriage fault. That can be caused by anything from debris/obstruction (paper jam, bent/damaged rails, out of place purge assembly/wiper, or dirty/dislocated encoder strip) to an actual hardware defect (bad sensor or control board, faulty carriage drive motor/gear/belt, bad printhead/carriage pcb).

What we can try here are some cleaning and reset steps.
First, open up the printer, and check for any internal debris such as scraps of paper, paperclip or staple, etc. Check if you’re able to move the carriage manually, or if it moves on its own when lifting the lid. If it does move, you can proceed with cleaning by blowing out the inside compartment with compressed air and checking carefully on both sides for any obstructions. Then wipe down the encoder strip, which is a clear plastic strip running the width of the printer, that sits just slightly above and behind the carriage.

Then reset the machine:
unplug power at the wall outlet
wait 5 minutes
press and hold the power/on button for 60+ seconds
keep holding while plugging back in, and for another 60 seconds after, then release

Let me know the results, and I’ll advise further if needed.

Thanks,

Nathan

Expert:  Nathan replied 3 months ago.

Do you need more help with this?
If so, simply reply back on this page.

Please note: You have already paid your fee to the site; I'd like to help you and provide value for that fee, but I do need to communicate with you here to do so.

Nathan