How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Electronics Pete Your Own Question

Electronics Pete
Electronics Pete, Engineer
Category: Printers
Satisfied Customers: 15469
Experience:  HNC Computing; Large format and multifunction printer expert
Type Your Printers Question Here...
Electronics Pete is online now
A new question is answered every 9 seconds

Equipment is Epson GS6000. We replaced the dampers on the

Customer Question

Equipment is Epson GS6000. We replaced the dampers on the CMYK printhead. Now no colors will print, even orange, green, lm and lc. No error messages, just no ink flows. However when cleaning the pump does pull ink through the printhead. But the spit pad is dry so the piezo is not pumping out ink for any of the colors.
JA: Can you guesstimate how old your Epson is? And just to clarify, what's the exact model?
Customer: Purchased 10/20/2011, Epson GS6000.
JA: What troubleshooting have you tried?
Customer: Multiple heavy cleanings and nozzle checks.
JA: The printer expert can solve this for you. Anything else you want him to know before I connect you two?
Customer: Before we replaced the dampers all colors were fine except for cyan.
Submitted: 2 months ago.
Category: Printers
Expert:  Electronics Pete replied 2 months ago.

Hi Ray,
I am Pete, and I'll be happy to assist with your question today.

The damper seals can stretch out after a while and will result in the pump being unable to create a vacuum (because it's sucking inair) no ink is pulled through the lines. I added o-rings to the dampeners and found that to solve the problem.

Kindly rate my service 5 stars at the top of your question page if my answer worked so I am rewarded for my time; tips appreciated :)
Otherwise please reply back if you need further assistance.

Customer: replied 2 months ago.
The problem is not with the seals. The vacuum pump pulls ink through the print heads during clean cycles. You can see it going down into the waste ink receptacle during a clean cycle. The problem is that now NEITHER print head (we only replaced the dampers on the CMYK head) will spit onto the spit pad or print anything at all during a nozzle check. No pattern at all in any of the colors.
Customer: replied 2 months ago.
To reiterate, the OGLMLC printhead was printing fine beforehand and we did not disturb it at all.
Expert:  Electronics Pete replied 2 months ago.

Ok, if the vacuum seals are good then I am out of ideas as to why it would suddenly stop working.

Let me check with the other techs on this...

Customer: replied 2 months ago.
Thank you for your response.

Related Printers Questions