How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Dr. Dan Your Own Question

Dr. Dan
Dr. Dan, Engineer
Category: Printers
Satisfied Customers: 1081
Experience:  B.S. Electrical & Computer Engineering, 20+ years technical experience
7043301
Type Your Printers Question Here...
Dr. Dan is online now
A new question is answered every 9 seconds

I bought a Canon PIXMA MG5720 but it is not compatible with

Customer Question

I bought a Canon PIXMA MG5720 but it is not compatible with my OS 10.5.8
1) Is there a printer driver that I can download to make it work?
2) If not, is your Canon MX922 compatible with OS 10.5.8. I see various responses online
PLease help me...ASAP
j
Submitted: 8 months ago.
Category: Printers
Expert:  Dr. Dan replied 8 months ago.
Hi there, unfortunately there is no drivers for OS 10.5 (Leopard). The printer was released much later than the operating system on your computer and Canon doesn't provide drivers for old operating systems. I would recommend that you consider upgrading OSX rather than trying to reverse engineering the printer to work with the older operating system. It looks like Canon support OSX from 10.7 and on for this printer.Let me know if this helps,Dan
Customer: replied 8 months ago.
Very disappointing. Some sources said MX922 wud work but others said no. I was hoping for a yes. I know my system is old....but so am I. Tks for your help.
Expert:  Dr. Dan replied 8 months ago.
This may not be as daunting a task as it sounds. Depending on your computer, have you looked into just updating OSX to say 10.7? I wish there was an easier solution to get a newer printer working on a old machine