How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Freddy M. Your Own Question
Freddy M.
Freddy M., Technician
Category: Printers
Satisfied Customers: 18398
Experience:  Years of IT and customer support experience
15852642
Type Your Printers Question Here...
Freddy M. is online now
A new question is answered every 9 seconds

Epson 7600: "No maintenance tank". Tried several MT/chip

Customer Question

Epson 7600: "No maintenance tank". Tried several MT/chip combinations, non recognized.
Wondering if the MT sensor is worn out (#664 in service manual: "PCB assy IC") I see 6 wire contacts, should there be 7? Did one break? Easy to replace, or is there a work-around? Thanks,
Mark
Submitted: 1 year ago.
Category: Printers
Expert:  Freddy M. replied 1 year ago.

Hello my name is***** do not rate until we are finished. I look forward to assisting and am very sorry to hear that you are having this problem. I want to warn you that it is possible you will need to replace a part in order to fix this. There are a few different things that can cause this and a couple different parts so we would need to troubleshoot to find out for sure. Have you tried replacing the entire maintenance tank yet? Just changing the chip on it does not always work.

Customer: replied 1 year ago.
I've 2 maintenance tanks, several sets of chips, no combination works.
Expert:  Freddy M. replied 1 year ago.

Do both of them have replaced chips? I actually meant replacing it with a new one that does not have a generic chip.

Customer: replied 1 year ago.
One of chips read "MT full" . That same chip now reads "No MT". It looks like the chip has 7 spots of contact. Looking closely at the chip reader after pulling the cover back reveals 6 wire pin contacts. One in the middle looks to be missing/broken? I believe I need a new MT chip sensor, #664 in exploded service manual diagram - "PCB assy IC". Are there supposed to be 7 wire pin contacts, not 6? (It does not show in diagram.) If so, is there a temp work-around till I find a replacement part?
Expert:  Freddy M. replied 1 year ago.

I apologize but I am going to need to opt out and open this to all experts.