How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask poolguy810 Your Own Question
poolguy810
poolguy810, owner - pool and spa service company
Category: Pool and Spa
Satisfied Customers: 1671
Experience:  Servicing pools and all brands of spas for over 28 years.
32482502
Type Your Pool and Spa Question Here...
poolguy810 is online now
A new question is answered every 9 seconds

Jacuzzi Blue Ridge Hot Tub. P51 error code. Circulating pump

Customer Question

Jacuzzi Blue Ridge Hot Tub. P51 error code. Circulating pump comes on for a second and then off. I can hear the relay click the circulation pump motor on and off. I have replaced the circulation pump motor, no improvement.
JA: Who manufactured the hot tub?
Customer: jacuzzi
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: no
Submitted: 2 months ago.
Category: Pool and Spa
Expert:  Webb-Guy replied 2 months ago.

Hello and welcome to Just answer. My name is ***** ***** I will be the one to try and assist you today.

I believe it is the pressure switch. Is or was your tub low on water? That PS1 code says" system checks the pressure switch for switch closure with circulation pump energized. If an error is detected the topside control display says "PS1" Automatic reset will occur if the condition is fixed in less than 5 minutes. Otherwise manual reset is needed.

Try adding some water, reset the GFI switch and see if it works.

Customer: replied 2 months ago.
It is full of water. It has been turned off and on, on several occasions. I can hear the relay click on and then the pump starts up for a second and then turns off. It does this about 3 times and then stops trying. I have replaced the circulation pump. I have replaced 2 pressure switches. After replacing the 2 pressure switches the main pump started working. Then I realized the circulation pump was not working so I replaced it.
Expert:  Webb-Guy replied 2 months ago.

Ok give me just a moment while I look into this. The fact that everything has been replaced that could be causing that is kind of mind boggling but I will see if there is anything else that can be checked. It certainly sounds like the pump is the problem possibly a bad connection with wires or something or the pump was defective when purchased. I will look into other things though bare with me for just a moment.

Customer: replied 2 months ago.
Are you still looking into this?
Expert:  Webb-Guy replied 2 months ago.

I am so sorry my last reply must not have went through. I have looked into everything I can and it certainly seems like the problem is with the pump I am not sure if its defective or something is off with the wiring. I can open this up for other suggestions.

Customer: replied 2 months ago.
Thank you
Customer: replied 2 months ago.
How long do I have to wait for an answer?

Related Pool and Spa Questions