How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask poolguy810 Your Own Question
poolguy810
poolguy810, owner - pool and spa service company
Category: Pool and Spa
Satisfied Customers: 1671
Experience:  Servicing pools and all brands of spas for over 28 years.
32482502
Type Your Pool and Spa Question Here...
poolguy810 is online now
A new question is answered every 9 seconds

I have a Pentair Mastertemp 125 Pool Heater Natural Gas When

Customer Question

i have a Pentair Mastertemp 125 Pool Heater Natural Gas When I turn it on it shows on the display 126 and does not fire
JA: Who manufactured the pool?
Customer: I don't know
JA: Do you plan on doing the work yourself?
Customer: Yes as I was told it is an easy replacement
JA: Anything else we should know to help you best?
Customer: no everything I read says its the Thermistor I just need to verify this and if so how to replace it
Submitted: 3 months ago.
Category: Pool and Spa
Expert:  Rick replied 3 months ago.

Welcome to Just Answer, my name is ***** ***** I will do my best to help you with your issue. If my initial response doesn’t answer your question then let me know and we can continue our conversation.

If it's displaying 126 it's telling you it think the water temp is 126 so it won't fire because it thinks the water is too hot. Are there any diagnostic LED's light on the back of the control board?

Customer: replied 3 months ago.
No, there are no other lights on...I am not sure what you mean by back of control board...there are three LED messages on the control panel which say Service Heater, Service System and Heating. None of these lights are on
Expert:  Rick replied 3 months ago.

You have to remove the control panel to get to see the back of the board.

Expert:  Rick replied 3 months ago.

Take the top of the unit off

Customer: replied 3 months ago.
The only lights on the control panel are the ones that light up what I replied before. Its definitely a bad temp reading as you said...I turned the unit back on and it read 76 and fired. Then the LED shot up quickly and shut the heater down
Customer: replied 3 months ago.
Then the LED reading started to fluctuate....go down to 107 back up to 118...up and down, up and down...
Customer: replied 3 months ago.
But never low enough to turn the unit back on
Expert:  Rick replied 3 months ago.

Sounds like you have a bad temp sensor

Customer: replied 3 months ago.
that is the Thermistor? Do you know of any instructions to replace it?
Expert:  Rick replied 3 months ago.

Just turn the unit off, disconnect the leads and unscrew it as long as the heater is at the high point of the system. If the heater is lower than the pool or spa then you need to isolate the heater. There should be valves to do so.

Expert:  Rick replied 3 months ago.

Do you know where it's located? do you have the manual?

Related Pool and Spa Questions