How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 22003
Experience:  Licensed in Hydronics and Boilers
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

I have an advante series spa with balboa instuments board. I

Customer Question

I have an advante series spa with balboa instuments board. I put chemicals in it and turned on pump 1 and 2 on high to circulate and about 15 seconds later pump 2 starts goin on and off and will not let me turn it off. I have turned power off several times. I replaced the 2 25amp time delay fuses but nothing has changed. ?
Submitted: 2 months ago.
Category: Pool and Spa
Expert:  Billy replied 2 months ago.

I am very sorry your question has not been picked up yet.

I just logged on and found you had not been assisted.

Please let me know if you still need help and I will do my best. Please do not "Rate" as we have not worked toward an answer yet.

If you would like to proceed let me know by replying

Customer: replied 2 months ago.
i still need help but first time trying this and not really impressed but i am a self employed person and don't like negative feed back. would just appreciate getting my spa going
Customer: replied 2 months ago.
can someone tell me how to get my money back so i don't have to leave a negative feedback or do i need to just call my credit card and dispute now

Related Pool and Spa Questions