How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask tomen99 Your Own Question
tomen99, Handyman
Category: Pool and Spa
Satisfied Customers: 111
Experience:  Certified pool operator and maintenance supervisor
Type Your Pool and Spa Question Here...
tomen99 is online now
A new question is answered every 9 seconds

I recently bought and installed a Hayward SwimClear C4030

Customer Question

I recently bought and installed a Hayward SwimClear C4030 filter. Installation was easy and directions were good. My pool cleared up pretty well but when I went to vacuum the pool it seems that everything goes right through and back into the pool. So now it is dirty on the bottom and a little cloudy. I have washed the filter cartridges and looked at them and they seem fine, the connections all look good. I do understand how it is suppose to work but this is the first cartridge filter I have had. Past filter was a SwimQuip DE filter.
Thanks *****
Submitted: 3 months ago.
Category: Pool and Spa
Expert:  tomen99 replied 3 months ago.
As long as the only way to get water back to the pool is through the filter either the cartridges aren't seated or there is a rip that opens under pressure.

Related Pool and Spa Questions