How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask poolguy810 Your Own Question
poolguy810, owner - pool and spa service company
Category: Pool and Spa
Satisfied Customers: 1671
Experience:  Servicing pools and all brands of spas for over 28 years.
Type Your Pool and Spa Question Here...
poolguy810 is online now
A new question is answered every 9 seconds

I have a Hayward Pump and Sand Filter set-up. On

Customer Question

I have a Hayward Pump and Sand Filter set-up. On RECIRCULATION mode, the system appears to be running fine. When i switch to FILTER mode, i get air bubbles coming through the return jets in the pool. The pump window is totally clear, so i know the bubbles are not coming from the intake side of the pool. Can something be wrong with the sand filter valve, media, or container itself?
Submitted: 4 months ago.
Category: Pool and Spa
Expert:  Poolservice123 replied 4 months ago.

Do the air bubbles come in all jets or just the ones closest to the filter system? Do you have a salt water generator on the system or an ozone system?

Customer: replied 4 months ago.
The air bubbles were coming in stronger at the jet closest to the filtration system and less at the second jet which is further away. I do not have a salt water system but there is a bromine canister in the line. However, for the purpose of testing, I had completely turned this system off to eliminate it from the possible cause.I may have acted a little too quickly asking this question. As it turns out, the bubbles are now gone. Before this issue I had air at the pump window because of a faulty union o-ring and failed Teflon tape. Once I repaired these, the bubbles disappeared on RECIRCULATION mode, but i guess the filter was still full of air. It took a hour or so for the bubbles to disappear once I had switched the system to FILTRATION mode. All is good with the system now. Thank you for your response.
Expert:  Poolservice123 replied 4 months ago.

I am glad you found your problem. I'm sorry for no response but we had a power surge that stopped all our computers as the internet also went down. If I can help in the future please let me know.

Customer: replied 4 months ago.
No, Thank you! Just having professional people like you around helps with people like me trying to fix their own things. Have a great day!

Related Pool and Spa Questions