How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 21995
Experience:  Licensed in Hydronics and Boilers
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

I have an error code pool, ok, yes. I plan on a little

Customer Question

I have an error code pool
JA: Sometimes pool issues that that you think will be really complicated end up being easy to fix. The Pool Technician I'm going to connect you with knows all the tricks and shortcuts.
Customer: ok
JA: Do you plan on doing the work yourself?
Customer: yes. I plan on a little problem solving...its not my hot tub so I do not know the specs
JA: Anything else we should know to help you best?
Customer: no
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Pool Technician about your situation and then connect you two.
Customer: I just cleaned the filter, topped off the water, switched off and then on, still its not heating or filtering just says pool or posh on the jet button, but the aux jet works
Submitted: 4 months ago.
Category: Pool and Spa
Customer: replied 4 months ago.
The error code is psol on a spa and posh, it is not filtering or heating, but aux jets do work
Expert:  Billy replied 4 months ago.


my name is Billy.

Is the main circulating pump running?

Customer: replied 4 months ago.
Im not sure how to check that. It does not filter when I hit "set" to filter
Expert:  Billy replied 4 months ago.


the very first thing that has to happen is a "pressure switch" has to close. This closes when the main pump starts pushing water through the system.

Without the main pump running the switch cant close thus nothing else happens.

Will you be troubleshooting the 220v to the motor yourself?

Customer: replied 4 months ago.
I have cleaned the filter (which was dirty), topped off water and turned system off then on, no changes, the aux jets work and so do the air bubble ones. Where do we go from here? The spa in sunk in a deck and I am not too sure how to access the motor
Expert:  Billy replied 4 months ago.

I do not know your particular installation...I can only tell you a side panel removes to expose the main pump. This pump gets power from a circuit board in the same section but behind another cover.

We need to test the black and red wire to the motor when it should be on. 220v present with no pump = bad motor.

NO 220v present with no pump is bad board.

As far as the sunken installation, I certainly hope whoever installed it planned on potential service access

Related Pool and Spa Questions