How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask poolguy810 Your Own Question
poolguy810
poolguy810, owner - pool and spa service company
Category: Pool and Spa
Satisfied Customers: 1671
Experience:  Servicing pools and all brands of spas for over 28 years.
32482502
Type Your Pool and Spa Question Here...
poolguy810 is online now
A new question is answered every 9 seconds

I have a 1998 Montego 750 spa. summers not all of the jets

Customer Question

I have a 1998 Montego 750 spa. For two summers not all of the jets have been working. We have replaced the pump and I am wondering if this problem could be in the control panel. I have checked that all the jets are turned on and the problem persists. I would like to get this fixed this summer. Currently there is no water in the spa. Also wondered if it could be the diverter valve....thanks for you help in this matter..
Submitted: 6 months ago.
Category: Pool and Spa
Expert:  Mike R. replied 6 months ago.

Hi my name is ***** ***** I have been in the plumbing field for 20 years. I will be glad to help you today. Does any water come out of the jets that are not working? Like low pressure in some and regular pressure in others? If you run the spa without the filter as a test do the jets work normally then?

Customer: replied 6 months ago.
Can't seem to get them to all work at maximum pressure at the same time
Expert:  Mike R. replied 6 months ago.

What happens if you try running it without the filter installed temporarily?

Customer: replied 6 months ago.
Currently there is no water in it...I was hoping to diagnose problem in case it is the diverted valve which would need to be replaced with no water in it....we empty it for the winter...
Expert:  Mike R. replied 6 months ago.

Does it have the same issue no matter the jet setting?

Expert:  Mike R. replied 6 months ago.

Has the filter ever been replaced?

Expert:  Mike R. replied 6 months ago.

Are the jets that have low flow in one area of the tub or does it seem to be random jets that are getting low flow? Do you have it wired to 120v or 240v?

Expert:  Mike R. replied 6 months ago.

When you fill it do you remove the filter and fill through the filter housing or do you put the hose in the tub? Do you have city metered water or well water with a water softener?

Related Pool and Spa Questions