How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 22116
Experience:  Licensed in Hydronics and Boilers
12672042
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

Vita spa essn LH jet problem only work in right corner faint

Customer Question

Vita spa essn LH jet problem only work in right corner faint flow out of other jets high speed pump only improves flow to right corner filter is good water level is good pumps are good checked for air lock ,I did change the diverter valves but it worked OK for quite some time now this problem. If I let the water level down below the jets I get flow out of them?could this be the diverter? Touch pad and control unit upgraded with hydro quip unit . I am getting a flow code once tub I s information day or two temp doesn't seem to match display thermometer shows 15 degree difference
Submitted: 7 months ago.
Category: Pool and Spa
Expert:  Billy replied 7 months ago.
I am very sorry your question has not been picked up yet.I just logged on and found you had not been assisted. Please let me know if you still need help and I will do my best. Please do not "Rate" as we have not worked toward an answer yet. If you would like to proceed let me know by replying. Once again use reply
Customer: replied 7 months ago.
Let's give it a shot
Expert:  Billy replied 7 months ago.
ok, you need to reevaluate the diverter.This is the only item that can "cheat" flow from some nozzles and not others.Check the divert and let me know result
Customer: replied 7 months ago.
Hi I have already done that they are new took it a part checked for blockage seems to be functioning no debri

Related Pool and Spa Questions