How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 22109
Experience:  Licensed in Hydronics and Boilers
12672042
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

I have a jet setter model j hot tub that we just purchased

Customer Question

Hello, I have a jet setter model j hot tub that we just purchased used. I'm not sure what the year model is. I think it's an 04-06. The ready light is flashing. I have unplugged the unit for ~45 seconds but the light still is flashing. I believe the circulation pump is working because there are bubbles coming out of th floor drain. Where should I start with troubleshooting this?
Submitted: 10 months ago.
Category: Pool and Spa
Expert:  Billy replied 10 months ago.

I am very sorry your question has not been picked up yet.

I just logged on and found you had not been assisted.

Please let me know if you still need help and I will do my best. Please do not "Rate" as we have not worked toward an answer yet.

If you would like to proceed let me know by replying. Once again use reply..not "rate".

Customer: replied 10 months ago.
I still need help. Thanks for the reply
Expert:  Billy replied 10 months ago.

on the box that surrounds the controls under the tub...do you see 2 -3 small buttons? Right hand side

Customer: replied 9 months ago.
Are you speaking of the black box that is behind the cover?
Expert:  Billy replied 9 months ago.

correct

Customer: replied 9 months ago.
Okay I will check when I get home after work tonight. What do I do with the buttons?
Expert:  Billy replied 9 months ago.

press them all and tell me if one snaps or clicks?

Customer: replied 9 months ago.
I do not see any buttons. I will add pics of the black box on the tub
Expert:  Billy replied 9 months ago.

the 2 cables on right...follow to where they go in the tub and post a pic of wht they attach to. It looks like this years model may have remote resets

Customer: replied 9 months ago.
The cables go to temp sensors I think. On the heater. I'll try to get a pic. It's dark so we will try our best
Expert:  Billy replied 9 months ago.

Thank you...this is the autoreset version.

If you turn all power off to tub for 1 minute..and then back on...does the same exact thing happen or does the unit try to run first?

Customer: replied 9 months ago.
There's a few clicks then the light starts to flash again
Expert:  Billy replied 9 months ago.

Ok you may see bubbles from drain but I doubt the main pump is running as it should.

Have you verified the ain pump runs?

Removed filters....and if needed do you have a meter to check power to pump?

Customer: replied 9 months ago.
The pump runs. There seems to be plenty of flow out of the jets. Would it help to have a video?

Related Pool and Spa Questions