How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 22245
Experience:  Licensed in Hydronics and Boilers
12672042
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

I bought a used hot springs jetsetter 2010 model, and we

Customer Question

Hi, I bought a used hot springs jetsetter 2010 model, and we used it today everything is fine, but i noticed the green light went off and we have been out of it for 3 hours now, I opened it up and it felt hot still, and then i ran the jets and noticed the green light came back on? is this a bad sign?
JA: Thanks. Can you give me any more details about your issue?
Customer: Also, i'm wondering about the ACE system. when we set it up it said to contact dealer for support, so we had the ACE cell unplugged. I noticed these cells are around 700$ could it be it's just dirty? should i try to soak it in some type of cleaner and try to hook it up ?
JA: OK got it. Last thing — Pool and Spa Experts generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 11 months ago.
Category: Pool and Spa
Expert:  Billy replied 11 months ago.

I am very sorry your question has not been picked up yet.

I just logged on and found you had not been assisted.

Please let me know if you still need help and I will do my best. Please do not "Rate" as we have not worked toward an answer yet.

If you would like to proceed let me know by replying. Once again use reply..not "rate".

Related Pool and Spa Questions