How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 22120
Experience:  Licensed in Hydronics and Boilers
12672042
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

I think my Jandy RS 8 controller is dead, but could also be

Customer Question

I think my Jandy RS 8 controller is dead, but could also be the transformer. Can you recommend a method that I might try to verify before ordering parts ? I have a multi-meter handy, and I know my way around the main control box pretty well.
JA: Thanks. Can you give me any more details about your issue?
Customer: All the lights on the Aquilink display are lit up. All buttons on the control board are non-responsive, including reset.
JA: OK got it. Last thing — Pool and Spa Experts generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 10 months ago.
Category: Pool and Spa
Expert:  Billy replied 10 months ago.

hello,

can you first tell me what power value enters the transformer and then the low voltage leaving?

Customer: replied 10 months ago.
Well, funny story. In trying to measure the primary and secondary on the transformer, the control board suddenly started working. Can't think of what I might have done that I didn't try a dozen times already - removed and retightened wire nuts on the input AC line, discarded the old 9V battery, pushed the reset again - but no forehead-slapping breakthroughs.Now everything is working - transformer seeing 120 VAC on the primary, putting out 27 VAC on the secondary. DC voltages on the red terminal bar seem about right: 9.5 V.
My spa remote doesn't work - I leave that connector disconnected to avoid the ghosting problems discussed here in another thread.Guess I didn't need the expert help after all, but never very comforting to fix something without knowing what you did.

Related Pool and Spa Questions