How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask poolguy810 Your Own Question
poolguy810
poolguy810, owner - pool and spa service company
Category: Pool and Spa
Satisfied Customers: 1671
Experience:  Servicing pools and all brands of spas for over 28 years.
32482502
Type Your Pool and Spa Question Here...
poolguy810 is online now
A new question is answered every 9 seconds

A sorrento hotspot hottub We haven't used our tub in a month

Customer Question

Customer: ***** ***** A sorrento hotspot hottub We haven't used our tub in a month maybe a little more. We went out there yesterday and the water is ice cold and the control panel is not working at all. We have reset the trip, shut off power to it and back on. we have a heater blowing into the opening hole. still nothing any ideas?
JA: Thanks. Can you give me any more details about your issue?
Customer: We are not sure what happened. we used it middle of november. but knew it was running between thanksgiving and christmas now all of a sudden we went out there and the small control panel lights up sometimes. gives the temperature. but the heater is not kicking in the jets wont turn on either
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Pool and Spa Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: yes
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 10 months ago.
Category: Pool and Spa
Expert:  poolguy810 replied 10 months ago.

What brand of spa is this and is the display showing any errors or anything at all?

Customer: replied 10 months ago.
It is a sorrento hotspot. It has power going to it because it shows the temperature then it disappears and has all ---. We have tried cutting off the power and back on. Also resetting the trip. Also have the panel open with a heater blowing under it since yesterday morning
Expert:  poolguy810 replied 10 months ago.

Is there any chance it was already iced up in the lines before you started trying to get it started up? The Dashes on the screen like that normally indicates that there's no water flow through the heater, so that could be a bad circ pump or if the circ pump has ice in it, it won't turn either. If nothing at all is running then we'd need to open it up and put your hand on the small circulation pump that's hooked up to the stainless steel heater to see if the pump is vibrating at all or if it's very hot to the touch.

Customer: replied 10 months ago.
We have had the heater blowing in the hole for about 36 hours now. He just went out to check what u were asking and the pump was running. It ran for about 30 seconds then shut off. And went back to the --- on the display
Expert:  poolguy810 replied 10 months ago.

Ok, is hard to see it, but when that pump comes on for that 30 seconds can you see if it's making the water move in the spa? That pump may not be doing anything, if that's the case then it wound need replaced. They normally have a life span of about 5 years or so

Related Pool and Spa Questions