How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask poolguy810 Your Own Question
poolguy810
poolguy810, owner - pool and spa service company
Category: Pool and Spa
Satisfied Customers: 1671
Experience:  Servicing pools and all brands of spas for over 28 years.
32482502
Type Your Pool and Spa Question Here...
poolguy810 is online now
A new question is answered every 9 seconds

I had a 2004 Hot Spring Spa. Just moved it and plugged it

Customer Question

I had a 2004 Hot Spring Spa . Just moved it and plugged it in. Worked fine for 3 cleaning cycles. Heater light was on. Went to test to spa light and lost all power when I turned the light on
Submitted: 1 year ago.
Category: Pool and Spa
Expert:  Fix my Pool and Spa replied 1 year ago.

It sounds like you have a dead short it sounds like you have a dead short in the light or a bad transformer. I would unplug the light from the circuit board then reset breakers to get power back on and if the spa runs ok then the light is bad and replace the light assembly. Check the fuses on the circuit board if the spa will not power up as you may have blown a fuse on the circuit board.

Customer: replied 1 year ago.
I worked it out before I got your answer. Keep the $5 but I'd really like the $25 refunded

Related Pool and Spa Questions