How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 22245
Experience:  Licensed in Hydronics and Boilers
12672042
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

I have just replaced a new spa pack that is connected to a

Customer Question

I have just replaced a new spa pack that is connected to a K9 top side controller; however it will not operate automatically, that is when I press the jets manually it will work fine, heats etc for 20 minutes then turns off until I hit the jet button again? The topside controller shows FLO when first turned on, this goes out the moment I press the jet button. When I press the temp button the light comes on and off, I have replaced the topside controller with no change?
As mentioned the spa appears to work fine manually, no tripping of power, all jets work and it heats up fine when I continue to press the jets on manually.
Any ideas?
Submitted: 1 year ago.
Category: Pool and Spa
Expert:  Billy replied 1 year ago.

hello,

Is the circulation pump itself running?

Is FLO on screen the entire time the jets are not on?

Customer: replied 1 year ago.
Flo is on the moment the jets stop, the pump works on speed 1 and 2 just does not come on automatically as it used to. The top side controller also has issues, press the temp up button the light goes on and off, this was also replaced making no difference. Is there a wring issue on the new spa pack? I have looked and everything appears to be right, and like I said it all works (other than the topside controller) if I press the jets manually, the heater, both jet speeds and the temp display.
Expert:  Billy replied 1 year ago.

there appears to be a wiring difference.

Were any functions missing prior to spa pack replacement?

Customer: replied 1 year ago.
Topside controller worked fine, the spa pack was replaced due to the heater failing, due to the age of the spa I thought it wise to replace the whole pack complete as there was a little corrosion etc. forming on some of the resistors and the like.

Related Pool and Spa Questions