How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 22098
Experience:  Licensed in Hydronics and Boilers
12672042
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

I have a Maax Spa, Rio model, purchased in 2002. I have just

Customer Question

Hi, I have a Maax Spa, Rio model, purchased in 2002. I have just emptied and refilled the spa after I discovered a leak at the join where the pipe leads into the heater unit. The spa had half drained before I noticed it was leaking. It appeared to be a bit loose and tightening the joiner appears to have fixed the leak. However, on start up the pump shuts down after a few seconds and the control panel beeps and displays 'H20'. The Owner's Manual does not have a trouble shooting guide so I have no idea what this means. Presumably the pump may need priming or the water sensor is not working but I have no idea how to check or fix this. The heater unit is a Spa Power 54500 Can you advise me please.
Submitted: 1 year ago.
Category: Pool and Spa
Expert:  Billy replied 1 year ago.

hello,

before removing something to burp air..try this.

turn unit on...turn on jets for 10 seconds and off 15 seconds...on 10...off 15...do that about 10-12 times and see if that purges the air

Customer: replied 1 year ago.
I had already tried this yesterday and have just tried again, and still no go. I turned unit at the power point, then pressed the auto/pump/heater button on the control unit and although I can hear the pump running it does not pump any water through the jets or filter and cuts out after about 10 seconds, still displaying H2O on control unit and after repeating about 10 times.
Expert:  Billy replied 1 year ago.

can you remove or loosen a fitting at/near pump and see if water present? Is pump impeller turning?

Customer: replied 1 year ago.
I am unable to check on this at the moment as it is raining here and the spa plumbing is difficult to get to. It might be a bit beyond me to loosen anything. The leaking pipe union behind heater unit was extremely hard to undo (I had assistance with this). Sounds like I may have to wait for a service person I phoned a couple of days ago to get back to me. Hard to find someone near here. I gather you are in the US, while I thought you were based in Australia (where I am).
Expert:  Billy replied 1 year ago.

I understand. I actually take questions from all over the world on spas, hot tubs and pools. The most popular ones are sold worldwide.

I wish you the best!

Billy

Related Pool and Spa Questions