How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Rick Your Own Question
Rick
Rick, HVAC Supervisor
Category: Pool and Spa
Satisfied Customers: 19483
Experience:  40+ yrs. experience as a licensed oil & gas technician.
94766
Type Your Pool and Spa Question Here...
Rick is online now
A new question is answered every 9 seconds

I have AO error code on Hayward heater. I followed the flow

Customer Question

I have AO error code on Hayward heater. I followed the flow chart and all is as should be. The blower is blowing but heater will ignite
Submitted: 1 year ago.
Category: Pool and Spa
Customer: replied 1 year ago.
Will not ignite
Expert:  Rick replied 1 year ago.

Welcome to Just Answer, my name is ***** ***** I will do my best to help you with your issue. If my initial response doesn’t answer your question then let me know and we can continue our conversation.
You could have a bad draft pressure switch, the fan could be clogged or the vac tubing to the switch could be kinked, deteriorated or blocked. After you rule out all these (except the bad switch) you can try jumping the 2 leads on the switch after the fan starts up (not before). If the burner fires up you probably have a bad switch.

Customer: replied 1 year ago.
Is the draft pressure switch the samething as the Blower vacuum switch?
Expert:  Rick replied 1 year ago.

Yes. Sorry for the delayed response I had to step away for a few

Customer: replied 1 year ago.
When I blow/ sick on tuning AO code goes away temporarily but does not ignite and error code returns
Expert:  Rick replied 1 year ago.

You need to jump the switch leads like I mentioned before.

Expert:  Rick replied 1 year ago.

Based on your description if the burner fires up when you jump the switch leads there's a high probability you need to replace the switch

Customer: replied 1 year ago.
When I jump leads I get bd error
Expert:  Rick replied 1 year ago.

Did you jump them after the fan started up?

Customer: replied 1 year ago.
Expert:  Rick replied 1 year ago.

Ok, then you probably have a bad board given your description so far. I'd try power the unit down wait a few minutes then power it back up and jump the switch leads again after the fan starts up. If you still get a bD error then the board is a likely culprit

Customer: replied 1 year ago.
ICB or fuse board
Expert:  Rick replied 1 year ago.

Fuse board

Expert:  Rick replied 1 year ago.

Before you replace the board check to be sure the FC4 fuse is good. Also check all your connections. I'm assuming this is an H series.

Customer: replied 1 year ago.
Replaced fuse. Now have LO error
Expert:  Rick replied 1 year ago.

LO is limit string open. Check the limits for continuity and try resetting the rollout switches

Customer: replied 1 year ago.
Now AO error again
Expert:  Rick replied 1 year ago.

Are you sure you've identified the draft switch? It sounds like you blew a fuse the last time. Jumping the switch after the fan starts shouldn't blow a fuse. If you're sure you need to try jumping the switch again

Customer: replied 1 year ago.
I took the wires off this and connected (jumped) them
Expert:  Rick replied 1 year ago.

That looks like the switch. So try jumping it again

Customer: replied 1 year ago.
When I jump the wires the blower ran shutoff ran again and then finally shut off and now I have an AC error
Expert:  Rick replied 1 year ago.

Check the switch connections at the board. If they're good it sounds like your ICB is acting up and is a likely culprit

Customer: replied 1 year ago.
I replaced the ICB and switch and still getting the same AO error
Expert:  Rick replied 1 year ago.

You are sure you don't have a bad lead from the switch? I don't have anything else to offer you. I'm going to open this backup to my colleagues so one of them can help. Please don't respond (even to acknowledge this post)until you get a response from us. If you respond first it will only delay your answer.

Customer: replied 1 year ago.
I have not heard back from anyone
Expert:  Rick replied 1 year ago.

It seems there was a glitch on our end. I'll repost to my colleagues.

Customer: replied 1 year ago.
Still waiting. How do I get my money back?

Related Pool and Spa Questions