How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask poolguy810 Your Own Question
poolguy810
poolguy810, owner - pool and spa service company
Category: Pool and Spa
Satisfied Customers: 1671
Experience:  Servicing pools and all brands of spas for over 28 years.
32482502
Type Your Pool and Spa Question Here...
poolguy810 is online now
A new question is answered every 9 seconds

I have a marquis spa, runs intermittently now, display is showing a 70, 72, 21, and then 2

Customer Question

I have a marquis spa, runs intermittently now, display is showing a 70, 72, 21, and then 24 on start up...also while running at times. Will run for a little while after shutting off power then sometimes it goes into Pr mode or sometimes display goes blank, want to know what that code means. Euphoria style spa, construction date of 2006.
Submitted: 1 year ago.
Category: Pool and Spa
Expert:  poolguy810 replied 1 year ago.
The pr will always show up when the spa is starting, that just indicates that it's trying to prime the pump with water, so that part is normal operating procedure. The other numbers you're seeing on startup are also normal, that's the circuit board reading the resistance values of the two sensors on the heater, so neither one of those conditions really indicate an error code. The fact that it's shutting off, and especially a blank screen when power is still on, indicates a bad circuit board problem. If you're not getting any actual error codes, the unfortunately the only remedy is replacing the board itself. I'll be happy to help out if you still have questions about this topic. Thanks, jeff
Customer: replied 1 year ago.
It goes into Pr after starting up sometimes though, when it has already run the priming and been in a running mode, which is incorrect, and those numbers cycle constantly when power is on now, not just at startup and they never did that before. Also, what about the temperature of my pump motor?
Expert:  poolguy810 replied 1 year ago.
On the motor issue, pumps run about 142 degrees normally, so they will usually feel pretty hot to the touch. They do have an internal thermal overload that will turn them off automatically if they overheat. The pr is going to show up anytime the pump or main power shuts off for even a second. That combined with the sensor readings constantly popping up is a definite sign of the circuit board malfunctioning.

Related Pool and Spa Questions