How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Technician
Category: Pool and Spa
Satisfied Customers: 22102
Experience:  Licensed in Hydronics and Boilers
12672042
Type Your Pool and Spa Question Here...
Billy is online now
A new question is answered every 9 seconds

I have a jac. z-110 spa ,i replaced topside last year but spa

Customer Question

i have a jac. z-110 spa ,i replaced topside last year but spa didnt heat althogh heat light came on. so i replaced heater this year when i started it up topside control worked for the pump but the heat status light didnt come on and hot tub didnt heat where do i go from here
Submitted: 1 year ago.
Category: Pool and Spa
Customer: replied 1 year ago.
any answers yet?
Expert:  Billy replied 1 year ago.
If the heat light does not come on means flow/pressure switch is not making contact. If the pump is running...check the flow switch.
Customer: replied 1 year ago.
I just got a chance to view your response and yes the pump runs and i can press topside button to swich speeds, before writing to this site, last week i did try to disconnect flow/ press. wires from board and jump connection but the power cord gfi would trip and nothing worked when reconnected to board pump worked but still no heat light . I will check wire contacts on flow pressure switch in morning (how else should I check this switch?
Expert:  Billy replied 1 year ago.
are you sure it was the flow switch you bypassed?...it should not have anything to do with pump assembly
Customer: replied 1 year ago.
I pretty sure it was flow switch, it screws into the top of heater and has 2 wires that clip on to contacts ,it might have been the temp sensor i dissconnected from board any way how do i test flow switch is making contact
Customer: replied 1 year ago.
I haven't heard from new expert
Customer: replied 1 year ago.
have not heard from a new expert and want to find out more info about pressure switch , would some one just answer my question
thanks

Related Pool and Spa Questions