How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask garrygoeson Your Own Question
garrygoeson, Home Appliance Technician
Category: Pool and Spa
Satisfied Customers: 469
Experience:  Over 27 years Repairing Pool & Spa Equipment,Gas Heaters,& Whirlpool Bath Tubs. Certified by many Pool & Spa Manufacturers.
Type Your Pool and Spa Question Here...
garrygoeson is online now
A new question is answered every 9 seconds

My Aqualink RS4 is frozen and shows a 6700 REV C message. All

Customer Question

My Aqualink RS4 is frozen and shows a 6700 REV C message. All the buttons are lit in either red or amper(yellowish orange). This just happens 24 hrs ago. All the buttons are non responsive. No time or date. I've tried resetting the unit w/ no change.
Submitted: 4 years ago.
Category: Pool and Spa
Expert:  Walt-mod replied 4 years ago.
I'm a moderator for this topic and I wonder whether you're still waiting for an answer. If you are, please let me know and I will do my best to find a Expert to assist you right away. If not, feel free to let me know and I will cancel this question for you. Thank you!
Customer: replied 4 years ago.
Yes I'm still waiting for an answer. Nothing has come through yet.
Expert:  Walt-mod replied 4 years ago.
Sometimes, finding the right Expert can take a little longer than expected and we thank you greatly for your understanding. We'll be in touch again shortly.
Expert:  garrygoeson replied 4 years ago.

Hi: my name is Garry


Do you have a spa -side remote? Sometimes, when these remotes short out they will give the response you're getting on your indoor panel. If you do have one, unplug it at the connection at the outdoor power center and see if this solves the problem

Customer: replied 4 years ago.
Relist: Incomplete answer.
I need to know if the unit needs replacement. I have a spa side as well, but I have to put the pool in service mode outside inorder for the pool to function.
Expert:  garrygoeson replied 4 years ago.

If you go to the outside power center, unplug the six wire connector(brown connector) located above panel. this is the connector for the spa side remote. If your RS 4 INDOOR CONTROLLER now works normally, you will have to replace the spa side control and NOT the INDOOR controller.


Please try this first. It may appear as though it's your indoor control, but I have had this happen before. the spa side will short out and make it appear as though the indoor control is faulty. If this doesn't solve the problem, then we can look for other ideas that may cause this.

Related Pool and Spa Questions