How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask poolguy810 Your Own Question
poolguy810, owner - pool and spa service company
Category: Pool and Spa
Satisfied Customers: 1671
Experience:  Servicing pools and all brands of spas for over 28 years.
Type Your Pool and Spa Question Here...
poolguy810 is online now
A new question is answered every 9 seconds

I have just replaced my Vita spa L500 circuit board

Customer Question

I have just replaced my Vita spa L500 circuit board with "Vita Spa Circuit Board PC Board for L500/LC500 (old 460084) (new 460100) Prior to this It was stuck on error MSG and H1 the back of the board was scorched. I can see why and fixed that.The new board is not the exact same model but was listed as the upgraded replacement. it required a transformer adapter 4 to 8 pin. I did the installation and spa is running ok EXCEPT for FLO flashing. I understand the heater is not receiving flow. I have removed/ cleaned the filter. I have made sure all valves /gates are open. Ifeel it is something small missing in the wiring. Any help?

I just figured it out!!!! One of the tranformer wires was not getting a good connection... frayed replaced = fixed  I need to cancel question!
Submitted: 5 years ago.
Category: Pool and Spa

Related Pool and Spa Questions