How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Pontiac Technician
Category: Pontiac
Satisfied Customers: 2373
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Pontiac Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I have a 2005 Pontiac grand prix that I have been working on

Customer Question

i have a 2005 Pontiac grand prix that I have been working on for days. I am an ase certified tech with 15 years experience, this one has me stumped. the car starts fine and runs fine when cold, once warmed up it starts stalling then will die, wont restart for ten minutes, while it will not start it has excellent fuel pressure and it has spark but does not have injector pulse. after checking several things and continuing to die on me I decided to put the car in park take out the key and open the door, I actually was going to start walking back to the shop, I got back in the car put the key in and it started right up. I repeated this process about six more times to make sure it wasn't a fluke. Every time when the car dies it will not start for ten minutes unless you put it in park, take out the key, and open the door, then it will start right up. Every
Submitted: 20 days ago.
Category: Pontiac
Expert:  Tool Hut replied 20 days ago.

Hi, My Name is ***** ***** for posting your question to just answer. I am a independent contractor for just answer. ASE Certified Master Auto Technician with 20 years experience. I am confident we can resolve your problem together.Please remember I don't know your skill level. I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies to get to a satisfactory resolution.There will probably be some equipment needed for a proper diagnosis. If you are not comfortable with this or do not have any test equipment please let me know ASAP. I also give you all of the information you may need in good faith expecting a positive rating. I typically do not recommend phone calls, This is an automated request. DO not accept without me telling you I am requesting it. I am not compensated for my time until you leave a positive rating. Your rating should be based on the service you received.

It is very likely that you are going to require the theft system programmed with an online subscription.

Customer: replied 19 days ago.
Okay, I have a scanner albeit its a small one, my modis is currently out of commission. I am thinking that the bcm may be faulty due to it not shutting the light of after ten minutes like its supposed to and that the car will only restart immediately after the door is opened, which is when the radio and all power is actually shut down. Am I correct in assuming that or do you think it is possibly something else.
Customer: replied 19 days ago.
also another strange symptom is the car can sit and idle in the driveway for an hour with no problems, even after it is warmed up and has already died a couple times, but as soon as you go down the road you can make it about 1/2 mile then it dies again. Weird it only does it when the car is moving in drive. And it does stall out first as if it is going into some kind of limp mode.
Expert:  Tool Hut replied 19 days ago.

When you replace the passlock module most of the time it will not learn the key manually. the theft system will not cause a vehicle to stall.

Customer: replied 19 days ago.
I just swapped out the ignition switch with the same results. When I say stall I mean it cuts down to about half power or under and has little to no accelerator response. Again though the car will not restart for ten minutes unless you take the key out of the ignition and open the door to shut off all accessory power then close the door put the key in and it fires right up. When it does die the security light Does Not come on so that is what is baffling me. Every time I scan it there are no codes saved or pending codes either.
Expert:  Tool Hut replied 19 days ago.

So when it wont start does the starter crank the engine?

Customer: replied 19 days ago.
the starter cranks, the plugs have spark, the fuel pump does pressurize the system, but the injectors have no pulse command from the computer. This goes on for about ten minutes or until you take out the key and open the door then it will fire right back up. After it dies and restart it will drive for anywhere from a minute to five minutes then it does it again with the exact same results. no codes at all.
Expert:  Tool Hut replied 19 days ago.

In the underhood fuse box can you check fuse 20 for power when it wont start?

Expert:  Tool Hut replied 19 days ago.

You will maybe have to crank engine to get power.

Expert:  Tool Hut replied 19 days ago.

I would start with checking PCM power and grounds. I have attached the connector views. 21 pages. NU3 is California emissions.

Customer: replied 19 days ago.
it has power on fuse 20 when it wont start.
Customer: replied 19 days ago.
The theft system/ bcm will cause a stalling/dying problem if there is an internal short.
Customer: replied 18 days ago.
I am not satisfied with your response time nor your "Expert" Answer. Please Opt out so that another tech can opt in and give a second opinion.
Expert:  Marvin the Mechanic replied 15 days ago.

Check the ground in this image #2. Make sure it is clean and tight.

Customer: replied 14 days ago.
I have already checked all the powers and grounds for good connection.
Expert:  Marvin the Mechanic replied 14 days ago.

Have you had a scan tool on the vehicle when it stalls. Check the ecm and bcm to see if either one show fuel disabled. This would indicate a theft system

Customer: replied 11 days ago.
I have had the scanner on it when it stalls and dies and it doesn't show that fuel is disabled and there is no theft light. I have already put a new BCM in it thinking it was probably something involving the theft system but it did not help. Same exact symptoms and problem. Again no codes during or after stalling situation. The weird thing is the other day it was really cold where I live and the car normally takes only about 20 minutes or less to start acting up from a cold start. Yet the day it was really cold it ran for about 40 minutes down the road without any issue. Also when the car stalls and dies, while trying to start it without doing the key out door open thing to reset it has a burning circuit board smell coming from the MAF area although the ecm is inside the air filter housing so im not sure which one is making the smell.
Expert:  Marvin the Mechanic replied 11 days ago.

Maybe try running the vehicle with the MAF unplugged. Possible bad MAF.

Another thing to check is when the vehicle stalls what is the voltage at the injector power feed. I had one that the voltage would drop to about 7 volts.