How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Pontiac Technician
Category: Pontiac
Satisfied Customers: 29456
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Pontiac Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Blower motor was giving problems had to wedge the connectors

Customer Question

Blower motor was giving problems had to wedge the connectors but now it doesn't run at all
JA: How many miles are on the car? Is it an automatic or a manual transmission?
Customer: 155000
JA: What is the model/year of your Pontiac?
Customer: 2000 Bonneville
JA: Are you fixing your Bonneville yourself? What have you tried so far?
Customer: I would like to try
JA: Anything else you want the mechanic to know before I connect you?
Customer: Is it possible that the connecting plug is bad and not enough contact?
Submitted: 7 months ago.
Category: Pontiac
Expert:  GM Tech (Cam) replied 7 months ago.

hi there, I am Cam.

if wedging the connector on the blower resistor helped for a time and now it does not, that means that the pins inside the connector or the resistor itself have failed.

What I would so is remove the connector and inspect the connector pins. They should be clean pale silver looking. If you see black, blue, burnt plastic or things are warped, that does suggest the connector is bad. If you should find the connector bad, you will need to replace the pigtail connector ( its the plastic with about 12" of wire that you splice to the existing wires) and the blower motor resistor. I would suggest putting some dielectric grease on the pins of the connector as well to prevent this issue from happening again.