How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Pontiac Technician
Category: Pontiac
Satisfied Customers: 2374
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Pontiac Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Have engine rpm bouncing up and down. When driving it dies

Customer Question

Have engine rpm bouncing up and down. When driving it dies as soon as my foot is off the throttle. I have engine codes p0107, p0108, p0641, p0651. At dealers recommendation, I have replaced the BCM, the crank relay and the MAP sensor. I can't find any vacuum leaks. This problem just happened suddenly.
Submitted: 8 months ago.
Category: Pontiac
Expert:  Roy Belding replied 8 months ago.

good afternoon my name is ***** ***** I will assist

do you mean the mass air flow sensor or the map sensor???

Roy

Customer: replied 8 months ago.
Map - manifold absolute pressure sensor
Expert:  Roy Belding replied 8 months ago.

ok, thanks,

try this. I sent you a picture of the mass air flow sensor. unplug it and see if the rpm stabilize.

number 2 in the pisture

Roy

Expert:  Roy Belding replied 8 months ago.

how are you making out

Customer: replied 8 months ago.
Just tried it but the car won't start at all now. It doesn't start with it plugged in or with it out. It seems like it is trying a little as I heAR a little engine knock.
Customer: replied 8 months ago.
I now have engine code p0068 and p0102
Customer: replied 8 months ago.
As well as the other ones
Expert:  Roy Belding replied 8 months ago.

ok, check the map sensor for a 5 volt reference signal. there should be 2 with 5 volts, key on engine off with the connector dis connected.

also, check the tps for 8 volt signal as well. the 641, 651 look like the key codes for this issue.

Roy

Customer: replied 8 months ago.
The map has three wires neg. Signal and 5v reference. When I put the multimeter on the neg and 5v I get 12v with key on engine off. I'm not sure where the tps is located on this vehicle.
Expert:  Roy Belding replied 8 months ago.

it is on the throttle body

12 volts??? not 5 volts

Customer: replied 8 months ago.
Weird I know. It looks like the theft detergent system somehow triggered after I unplugged the maf. The display now shows start has been disabled. I have tried to do the relearn procedure with the key for thirty minutes but it hasn't worked. Any ideas? I will check the TCS tonight.
Customer: replied 8 months ago.
I mean tps
Expert:  Roy Belding replied 8 months ago.

is the security light blinking??

Customer: replied 8 months ago.
No. Just the display says start disabled. I haven't seen the security light in the instrument cluster turn on at all.
Expert:  Roy Belding replied 8 months ago.

ok, let me know the tps voltage

Customer: replied 8 months ago.
Tps is also at 12v. It is starting now but the display still shows starting disabled due to theft system. It is still shuttering at startup but seems to stabilize after giving it some gas for a while.
Expert:  Roy Belding replied 8 months ago.

without me being there, I cannot get a handle on this.

I am going to open it up to the other guys and see if they have any better ideas

Roy