How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Pontiac Technician
Category: Pontiac
Satisfied Customers: 2373
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Pontiac Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I have a 2000 grand am gt with 3.4.car sat .engine started

Customer Question

Hi I have a 2000 grand am gt with 3.4.car sat for 2yrs.engine started knocking at 159000.got a 2004 I,Paula engine in good running shape but took heads off old engine and rebuilt them because they had emission tubes in them and the 04 engine didn't.anyway put together and seems to run good other then my problem.since back together not all the time but if I was stopped and seems when taking off to the right I hit the gas and car would just cut rite off no stumble or sputter.but would start rite back up.seemed to have a flt spot or hesitation when taken off.I'd did it few times on my wife went to pull out from stop in to traffic and just cut off.so I changed mass air,tips,IAC,cleaned throttle body,injectors from the beginning,coils and control module,both Frank sensors.I drove it maybe 20 miles seem to be good.my wife drove about the same and said think its good,then little later said just cut off while she was just sitting idling in a parking lot.said started rite back up.I'm thinking something electrical.but any input would be thankful.
Submitted: 1 year ago.
Category: Pontiac
Expert:  Reggie Whiddon replied 1 year ago.

Have you scanned for codes? You seem to have replaced alot of the components that would cause such a problem, I would look at the ignition switch it could cause your problem and we all know the problem with those ignition switches. Check or replace with new