How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask jazzmaster Your Own Question
jazzmaster, ASE Certified Technician
Category: Pontiac
Satisfied Customers: 2951
Experience:  ase certified
Type Your Pontiac Question Here...
jazzmaster is online now
A new question is answered every 9 seconds

2005 Pontiac Montana: 3.4L, with 125 amp running

This answer was rated:

I have a 2005 Pontiac Montana, 3.4L, with 125 amp alternator. The Battery light comes on after the car warms up. I get a reading of 12.56 volts on the battery with the ignition off, and 13.6 to 14.0 volts with the car running. the voltage remains steady even as I turn on as many accessories as possible. Do I need to put a new alternator in?

hi, my name is XXXXX XXXXX I will try to help you .

the charging voltage looks good and you did check the connections at the alt ,so at this point if this was my vehicle ,I would take off the alternator and run it to a parts store and have them check it before you buy an alt.

as a note: the voltage regulator is most likely the issue as far as the charging light is concerned.

it will still charge its just the circuit to the light ...jazzmaster...

jazzmaster and 6 other Pontiac Specialists are ready to help you
Customer: replied 4 years ago.
I swapped out the voltage regulator, and still have a warning light. Voltage reading ~14.0v running, 12.6 at the battery when off.

you might want to get this checked, at most auto parts stores they will do this for free.

it could be that the alternator is bad ,even though you put a new regulator ,it may have a bad diode in it and a good tester machine will tell if that is the issue. the voltage looks ok,it should show a little higher, around 14.5-14.8 .

Customer: replied 4 years ago.
Auto Parts store tested it after I swapped out the regulator, and their machine passed it. Auto Zone did the test.
did they test it on the vehicle ?
Customer: replied 4 years ago.
Yes. Prior to the swap, the store tested alternator on the vehicle. I was told the voltage regultor did not pass, and the starter was drawing too much amperage. I have reinspected cables, but so far haven't seen an issue. as info, the aternator passed the in store test machine prior to the swap, also.
its getting late and I have to be at work very early ,can we continue tomorrow ? in the meantime I am going to study the wiring schematic and do some more research