How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee, Pontiac Technician
Category: Pontiac
Satisfied Customers: 24129
Experience:  ASE certified Technician advanced level specialist. Wisconsin certified emissions state inspector
Type Your Pontiac Question Here...
Amedee is online now
A new question is answered every 9 seconds

i get (pcm) U1016 - Loss of Class 2 Communication with VCM

Customer Question

i get (pcm) U1016 - Loss of Class 2 Communication with VCM and car doesn't starts up for 3 secons then stalls. 1999 pontiac sunfire
Submitted: 6 years ago.
Category: Pontiac
Expert:  Amedee replied 6 years ago.



Diagnostic Codes: U1016




1. Unplug the Antilock Brake System (ABS) module, air bag module and Instrument Panel Cluster (IPC) one at a time to see if communication comes back with the other modules.

2. Check for a 5 volts digital signal at the Data Link Connector (DLC) pin 9. If there is no signal at pin 9, unplug all of the module and check for a continuity between pin 9 and ground.

3. If there is continuity between pin 9 and ground check the data wire for shorts to ground.


Potential Causes:


Air Bag Module
Antilock Brake System (ABS)
Grounded Data Line
Instrument Panel Cluster (IPC)

U1016 Serial Communications Malfunction


Possible Causes
Perform the Diagnostic System Check for Engine Controls
Check the connector for a problem (check pins for damage, and for moisture)
UART data line is open
UART data line is shorted to ground
UART data line is shorted to voltage

Amedee and 5 other Pontiac Specialists are ready to help you
Customer: replied 6 years ago.

cluster works but no rpm and heat temp gauge


Expert:  Amedee replied 6 years ago.
Well, I would be willing to bet that your instrument cluster is bad.

Related Pontiac Questions