How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask zzdaryl Your Own Question
zzdaryl
zzdaryl, Shop Owner, Master Mechanic
Category: Pontiac
Satisfied Customers: 12547
Experience:  28 years experience, Master Mechanic
8994801
Type Your Pontiac Question Here...
zzdaryl is online now
A new question is answered every 9 seconds

grand am cranks wont start no injector pulse theft light on

Customer Question

grand am cranks wont start no injector pulse theft light on but not flashing
Submitted: 7 years ago.
Category: Pontiac
Expert:  zzdaryl replied 7 years ago.

 

Below is a test procedure to follow, if the relearn does not help check all fuses to see if they are good.

 

 

 

 

 

 

1. After having cranked the engine, leave the key in the run position and check operation of the theft or security light. If the light is flashing or on steady, perform a theft relearn procedure.

 

( 1. Perform a security system relearn. 2. Let the vehicle sit for more than 10 minutes with the key off. 3. Attempt to start the engine, leave the key in the run position monitoring the security system indicator. 4. After 10 minutes, the security indicator will change state. 5. Turn the key off and wait 10 seconds. 6. Attempt to start the engine. If the engine stalls, wait another 10 minutes with the key on. 7. After the second 10 minute timer has expired, turn the key off for 10 seconds. 8. Attempt to start the engine. If the engine stalls, wait another 10 minutes with the key on. 9. After the 3rd 10 minute timer has expired, shut the key off for 10 seconds. 10. The security system will relearn on the 4th starting attempt and the engine should start and run.)



2. Verify power to the injector while engine is cranking.

3. If relearn procedure does not help, check the operation of the passlock sensor. The White wire should have battery voltage and remain above 10 volts while engine is cranking. The Yellow wire should have 4 volts and change to a voltage between 0.9 and 4.0 volts as key is rotated to the start position. It should maintain that voltage value as the key is released back to the run position.

5. Check to see if the A/C BFC fuse is blown. If blown this could cause loss of injector pulse with theft or security light operating normally.

Customer: replied 7 years ago.
have tryed all that fuse and volts to pass lock good i am getting power to injectors while cranking
Expert:  zzdaryl replied 7 years ago.
You did try the relearn procedure?

Edited by zzdaryl on 11/29/2009 at 3:42 PM EST
Customer: replied 7 years ago.
yes a couple of times but no luck when i turn key on the theft system light stays on does not flash
Expert:  zzdaryl replied 7 years ago.
After you try to start the engine does the theft system light still stay on?
Customer: replied 7 years ago.
yes i am getting fuel have power to injectors on th egrey wire while cranking still not getting any pulse thought that might helps
Expert:  zzdaryl replied 7 years ago.
You might try unplugging the TPS (throttle position sensor) to see if the pulse returns, it could be stuck at wide open throttle and that would cause no pulse.
Customer: replied 7 years ago.
i will go and try that now i will let ya if it does not work thanks
Expert:  zzdaryl replied 7 years ago.
Ok, good luck
Customer: replied 7 years ago.
no did not work now that i have been tryen to reset theft system i no longer even have power on grey going to injectors when cranking engine over
Expert:  zzdaryl replied 7 years ago.
Do you know if there is spark?
Customer: replied 7 years ago.
yes when i spray starting fluid in tbi it will fire. recheck all grounds this engine was just rebuilt ran when i took out but had 2 spun bearings complete rebuild
Expert:  zzdaryl replied 7 years ago.
If you have power to the injector when not cranking can you check the actual voltage? You might also check the connections to the injector harness for being plugged in all the way and not corroded inside the connector or pins pushed out.
Customer: replied 7 years ago.
no no power when key is off or do i have power when we crank it over i used to get power on grey when cranking but sense i have tryed to reset anti theft i no longer have power
Expert:  zzdaryl replied 7 years ago.
You should have power on one side of the injector when ever the key is cycled on for 3 seconds if you do not check the FP-INJ fuse in the engine compartment fuse box (if the fuse is good see if it has power to it). Do you have power with the key just turned to the on position?

Edited by zzdaryl on 11/29/2009 at 8:48 PM EST
Customer: replied 7 years ago.
i did have power to the grey on all 4 injectors when i did the theft relearn i lost power on that wire before relearn i had power with key on this thing is driving me nuts i will go out and check fuse the theft light is on steady when i put key in on position it does not blink
Expert:  zzdaryl replied 7 years ago.
The theft relearn should not affect the power to the injectors in any way so I'm not sure how that could have happened.
Customer: replied 7 years ago.
me either i am getting ready 4 work will get with u on mon hope that is ok you have been alot of help so far i hope we can figure this out
Expert:  zzdaryl replied 7 years ago.
Let me know the results.

Related Pontiac Questions