How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marc Your Own Question
Marc, Plumber
Category: Plumbing
Satisfied Customers: 1126
Experience:  Plumbing heating & home maintenance contractor
Type Your Plumbing Question Here...
Marc is online now
A new question is answered every 9 seconds

Unit not heating, tempura plus model, verified that correct

Customer Question

unit not heating , tempura plus model, verified that correct electrical voltage is connected properly. Unit will not heat . Jim
JA: Did you double-check the thermostat? And what about the unit's filters?
Customer: No, read the filter cleaning tutorial and can check , can that cut out the unit completely? Digital screen on door not lit either.
JA: Do you plan on doing the work yourself?
Customer: If I can>
JA: Anything else we should know to help you best?
Customer: This unit is 5 years old , it probably has not been serviced since install. I can usually handle routine maintenance of conventional electric water heaters. If you think I should go to plumber, I will recommend that to my customer. jim
Submitted: 27 days ago.
Category: Plumbing
Expert:  Rick replied 27 days ago.

Welcome to Just Answer, my name is ***** ***** I will do my best to help you with your issue. If my initial response doesn’t answer your question then let me know and we can continue our conversation.

If the digital display is not lit then either there is no power to the unit of the controller has failed. Did you put a volt meter on the connections at the unit?

Customer: replied 27 days ago.
Rick -I checked only the power source to unit , I will use voltmeter to try and see that power is reaching the control connections to heater element , I questioned that the heating unit may not have been energized because there was a blank screen at unit mounted on the door. I wondered if there may have been a fuse or something defective. The maker of this system really seems to offer little or no on-line information for trouble-shooting. jim
Expert:  Rick replied 27 days ago.

Yes their support is poor. Let me know what you find when you do the voltage testing. There is no fuse other than the breaker in your electrical panel. Nothing between the breaker and the control board

Expert:  Rick replied 25 days ago.

How did this work out?

Related Plumbing Questions