How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron, ASE Certified Technician
Category: Oldsmobile
Satisfied Customers: 33086
Experience:  35 years in the Auto repair business
Type Your Oldsmobile Question Here...
Ron is online now
A new question is answered every 9 seconds

Have 2001 olds Aurora 3.5 Have window problem drivers window

Customer Question

Have 2001 olds Aurora 3.5 Have window problem drivers window works other 3 not either by master control or individual controls door lock operates on drivers door only power mirror on drivers door only checked all fuses and circuit breakers good any suggestions.
JA: Most vehicles have two fuse panels. Have you located both?
Customer: Yes
JA: Are you fixing your Aurora yourself? What have you tried so far?
Customer: Yes I have replaced the door module no change
JA: Anything else you want the mechanic to know before I connect you?
Customer: I did replace the drivers rear window regulator assembly plastic gear stripped. Car sat for a while had some water in floor from window gap while waiting for regulator installation
Submitted: 12 days ago.
Category: Oldsmobile
Customer: replied 12 days ago.
I checked all fuses ones under the seat and under the hood
Expert:  Ron replied 12 days ago.

Hello. My name is ***** ***** I am happy to assist you today. Give me just a moment to review your post, and I'll be right back with the help you need.

Expert:  Ron replied 12 days ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here. On common cause for the problem you are having can be caused by a bad splice in the wiring at splice 302 which is located under the carpet at the drive seat. In order to determine if in fact that is the case you are going to need to dos some testing. I have enclosed the steps in the link below.

See the splice location in this link as well.

Related Oldsmobile Questions