How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, ASE Certified Technician
Category: Oldsmobile
Satisfied Customers: 15730
Experience:  over 25 years as a GM master tech
19513769
Type Your Oldsmobile Question Here...
Gary is online now
A new question is answered every 9 seconds

Oil is not going to cylinder heads. I checked the oil

Customer Question

Oil is not going to cylinder heads. I checked the oil pressure and at idle reads 20psi when at higher RPMs maxes out at 35 - 36 psi.
JA: How old is your oil pump? Has the check engine light come on?
Customer: Is there a way to unclog the oil passages that take the oil to the heads?
JA: What is the model/year of your Oldsmobile?
Customer: 98 olds sillhouette with 1 3.4.
JA: Are you fixing your 98 yourself? What have you tried so far?
Customer: Changed oil filter and it looked free from sludge, testest pressure an it's at 20psi at idle and 30 - 36 at higher RPMs.
JA: Anything else you want the mechanic to know before I connect you?
Customer: It started a squeaking noise over cylinder 3 and 5 and I get code miss-fires on and off on cylinder 5.
Submitted: 2 months ago.
Category: Oldsmobile
Customer: replied 2 months ago.
just removed the front side valve cover and it looks very dry inside. I ran the engine and there is no sign of oil going to the heads. The oil pressure is still 20 psi at idle and 30psi when accelerated. I feel like there is a blockage between the oil pump and the cylinder heads rocker arms. The noise that comes from cylinder 3 or 5. I also gets code po305 - cylinder misfire. My question: is there a way to unclog the lines/passage ways that carry the oil to the top of the engine?
Expert:  Gary replied 2 months ago.

I am sorry for the long wait

have you pulled out any pushrods and checked and seen if any have the center oil holes plugged up ?

Expert:  Gary replied 2 months ago.

how are you making out ?

Related Oldsmobile Questions