How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tims Auto Repair Your Own Question
Tims Auto Repair
Tims Auto Repair, Auto Mechanic
Category: Oldsmobile
Satisfied Customers: 15761
Experience:  have owned repair shop for 25 years
14541291
Type Your Oldsmobile Question Here...
Tims Auto Repair is online now
A new question is answered every 9 seconds

I have 1989 old 3.8 motor replaced upper and lower intake

Customer Question

I have 1989 old 3.8 motor replaced upper and lower intake gasket Maf sensor iact car start right up then die if I un plug Maf or. Iact car will run
Submitted: 7 months ago.
Category: Oldsmobile
Expert:  Tims Auto Repair replied 7 months ago.

Hi, My name is ***** ***** for the delay.
I will do my best to assist you.

Expert:  Tims Auto Repair replied 7 months ago.

does the engine light stay on?if so,can you give me the trouble codes?

Customer: replied 7 months ago.
No codes
Customer: replied 7 months ago.
The car has 88k it run great when it dose
Customer: replied 7 months ago.
Ware you there
Expert:  Tims Auto Repair replied 7 months ago.

sorry,,i am having nternet trouble

Customer: replied 7 months ago.
If I hook up old Maf sensor and do not put it int body car runs fine putt body car will not run
Expert:  Tims Auto Repair replied 7 months ago.

are you saying it will run without the maf sensor?please explain

Customer: replied 7 months ago.
It runs good with out Maf got new one put in car starts and die got other Maf thought the first was bad same thing if I hook up old will run but when I put in t body car will not run
Expert:  Tims Auto Repair replied 7 months ago.

and it doesnt give any code at all?

Expert:  Tims Auto Repair replied 7 months ago.

can you keep the engine running by giving it throttle?

Expert:  Tims Auto Repair replied 7 months ago.

can you keep the engine running by giving it throttle?

Customer: replied 7 months ago.
Customer: replied 7 months ago.
Let of gas dies
Expert:  Tims Auto Repair replied 7 months ago.

ok...does it do this when the engine is hot and cold?

Customer: replied 7 months ago.
When cold I replaced temp sensor to
Expert:  Tims Auto Repair replied 7 months ago.

but,,it runs well hot?

Customer: replied 7 months ago.
Some times
Expert:  Tims Auto Repair replied 7 months ago.

ok

sense you get no codes and from the way you explain,,there are a couple of things that come to mind..

Expert:  Tims Auto Repair replied 7 months ago.

1-the tps[throttle position sensor

2-the egr valve.

remove and clean the egr valve..

you may need to replace the tps..either of these may do this and not give a code on this year model

Customer: replied 7 months ago.
Ok I'll try it and get back to you
Customer: replied 7 months ago.
I put a new Tps on it was doing the same thing I'll try the egr and get back to you
Expert:  Tims Auto Repair replied 7 months ago.

ok

thanks

Customer: replied 7 months ago.
Ok clean egr was stick got it to free up still same thing keep foot on gas 1100rpm any lower dies
Customer: replied 7 months ago.
If dis connect tips runs at 2000rpms
Customer: replied 7 months ago.
How much power do I have to have going to tps
Expert:  Tims Auto Repair replied 7 months ago.

give me just a moment,,i will give you tests

Expert:  Tims Auto Repair replied 7 months ago.

another thing you may want to look at is the vacuum to the power brakes..the booster may be leaking,,,unplug the vacuum and plug the line to see if that makes a difference

Customer: replied 7 months ago.
Ok
Expert:  Tims Auto Repair replied 7 months ago.

Voltage0.40 +/- 0.05 V

Expert:  Tims Auto Repair replied 7 months ago.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/69c589buityiha7/0920-olds-MPFI%20Throttle%20Body.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/69c589buityiha7/0920-olds-MPFI%20Throttle%20Body.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Customer: replied 7 months ago.
Now it running good at 900rpm if I give it go up to 4000 and cuts in and out
Expert:  Tims Auto Repair replied 7 months ago.

the engine cuts in and out?

Customer: replied 7 months ago.
When gets up to 4000rpm
Expert:  Tims Auto Repair replied 7 months ago.

ok

if that is the case,,i now think your problem is the ignition module..the ignition module is located under the coils..i dont know of a good test you can do for it,,you need to replace it

Expert:  Tims Auto Repair replied 7 months ago.

thanks

Customer: replied 7 months ago.
Now the car runs when warm upi
Customer: replied 7 months ago.
Car run good when warm up but when hit gas it drop down and some time stall
Customer: replied 7 months ago.
I need more help
Customer: replied 7 months ago.
Opt. Out