How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Oldsmobile
Satisfied Customers: 44493
Experience:  16 years of experience
2499435
Type Your Oldsmobile Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Just shuts down! from hiway speed & arbitrarily just loses

Customer Question

just shuts down! from hiway speed & arbitrarily just loses power & stalls
JA: Is the check engine light on? Does the car stall at idle or when driving?
Customer: only when driving, warn lights don't come on until completely stalled
JA: What kind of car is it? Toyota, Honda, Ford, Chrysler, etc.
Customer: Olds Alero 2001
JA: Tell me a bit more about what's going on so he can help you best.
Customer: started doing this a couple of days ago (only have the car for about 2 months) drove approx 140 mile, on return trip for approx 120 miles, running approx 65 mph just lost power then completely shut off, no throttle response; then 2 days ago it shut downseveral times after driving approx 70 miles then reduced distance to 50, & approx 25 miles intervals
JA: Are you hoping to fix this yourself?
Customer: yes but if not able towill bring to a mechanic (licensed!) mostly hoping to get an idea of what the prob is ??fuel filter, pump or ignition switch (it was a part of the GM recall)notsure if it was replaced or what the symptoms are, we only have Olds key & factory fob onkeyring
JA: Great! What have you tried so far?
Customer: just checked air filter, which had moderate/light dust have also checked gas cap tightness as this occurred after trip to Oregon (with attendants serving gas) checked oil level; engine temps have been running in the warm range (just at the bottom of mid line
JA: Is there anything else important you think the Mechanic should know about your car?
Customer: 4 way flasher switch has been removed from dash & not replaced prior to our purchase!! car has 200,000 miles on odo but seems to run strong also thinking of catalytic converter as possible culprit?
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mechanic about your situation and then connect you two.
Submitted: 6 months ago.
Category: Oldsmobile
Expert:  Chris (aka-Moose) replied 6 months ago.

Welcome, I'm Chris (aka Moose). I normally log in after 3 pm central. Please make sure to let me know exactly what is needed from me so I can provide EXCELLENT 5 STAR service.

Sorry for the delay, I was busy most of the day today. I do not know why no others took the plunge on this concern, but I am willing to if your still needing help after this excessive wait time.

Expert:  Chris (aka-Moose) replied 6 months ago.

Hello again Chris here,

1) When customers come to Just Answer the website and the experts want them to have a great 5 star experience.

2) We also want them to be so pleased that they come back for future needs.

3) I have the feeling you were not pleased with my help because the post was not rated and or you need me to help more. If so please do reply.

4) I have an option for an additional fee to upload diagrams, repair guides, find a repair facility, or call you if that would help.

Thanks Chris

Customer: replied 6 months ago.
I didn't know I would be billed an additional amount, I was charged $5 from my debit card but not the entire ?$24. I couldn't open the text message thru my phone (not a "smart phone" ) it's a flip phone so I will have to wait ....
Customer: replied 6 months ago.
also I do not see any answers to my concerns thru this message after hitting view
Expert:  Chris (aka-Moose) replied 6 months ago.

I have nothing to do with the fees, I just answer questions. Do you still need help?

Customer: replied 6 months ago.
ok Moose I got your text, went to the Web site & nothing related to my problem was listed. also nothing in this correspondence dealing with my car problems
Customer: replied 6 months ago.
I will search for the answer myself
Customer: replied 6 months ago.
I will not bother rating this service as I feel my questions weren't addressed, no further correspondance please, thank you dave.rummell
Expert:  Chris (aka-Moose) replied 6 months ago.

Thanks for letting me know your not in need of assistance any longer.

Related Oldsmobile Questions