How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 598
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

Gas Gauge not working, replaced the floater gauge, s& spent

Customer Question

Gas Gauge not working, replaced the floater gauge, s& spent 200$ at Nissan to find problem, they didn't. Do you have access to Electrical drawings for Nissan X-trail SE 2005. I enjoy this car and its' going to take some work to keep it on the road, but would like to try. Thx
JA: Has the vehicle turned into a gas hog? And how does it start -- same as usual?
Customer: Starts same as usual. Gas hog: the winter, going into all wheel etc is costing a little more, it's running now at about 12 l per 100, 10 in summer
JA: What is the model of your '05 Nissan?
Customer: X-Trail SE
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: No, my garage: I repeat: I spent 400$ replacing floater on right side, at my garage. Went to Nissan and spent another 200$ for them to check and found nothing, assuming the fuel pump must be still working on the left side of car
JA: Anything else you want the mechanic to know before I connect you?
Customer: Engine light problem
Submitted: 3 months ago.
Category: Nissan
Expert:  Ron replied 3 months ago.

Hello. My name is ***** ***** I am happy to assist you today. Give me just a moment to review your post, and I'll be right back with the help you need.

Expert:  Ron replied 3 months ago.

have you scanned the system to see what the fault code and or codes are that should be setting?